BlastIQ™ Mobile August 2026 Release 1.30.325

Scheduled for Aug 31, 11:00 - 11:30 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 26, 2026 - 20:07 AEST

Scheduled

The BlastIQ™ team will be releasing a new version of BlastIQ™ Mobile that contains new features and bug fixes.

Please refer to the release notes here: https://support.blastiq.com/hc/en-us/articles/59151156118937
Posted Aug 26, 2026 - 15:01 AEST
This scheduled maintenance affects: BlastIQ™ Mobile.