BlastIQ Insights - Web Portal not Accessible
Incident Report for BlastIQ
Resolved
This incident has been resolved.
Posted Jun 25, 2020 - 18:04 AEST
Update
We are continuing to investigate this issue.
Posted Jun 25, 2020 - 18:04 AEST
Update
We are currently investigating an issue that is preventing users from accessing BlastIQ Insights.
Posted Jun 25, 2020 - 17:22 AEST
Investigating
We are currently investigating this issue.
Posted Jun 25, 2020 - 17:20 AEST
This incident affected: BlastIQ Insights.