Issues signing in to support portal
Incident Report for BlastIQ
Resolved
This incident has been resolved.
Posted Oct 13, 2023 - 11:30 AEDT
Investigating
We are investigating issues being experienced with login for https://support.blastiq.com
Posted Oct 13, 2023 - 10:27 AEDT
This incident affected: BlastIQ™ Platform (User Sign In).