Issue with site invitations
Incident Report for BlastIQ
Resolved
This incident has been resolved.
Posted Oct 13, 2023 - 11:25 AEDT
Investigating
An issue has been identified with the site invitations admin feature.
Invitations will be delayed until the issue is resolved.
Posted Oct 13, 2023 - 08:47 AEDT
This incident affected: BlastIQ™ Platform (Administration Portal).